There may be several reasons why your PayPal button isn't working correctly.

1. You may be using the "visual editor" to make your post on the Warrior forums. The code for the Buy Now button is written in BBcode, the language that is used by the forums, which doesn't paste very well in the visual editor.

There are two ways to fix this:

1. The first is to manually add in the button image, and then the link behind it.

To accomplish this, you will need to click on the "image icon" and then paste the URL of the image location of your payment button. (This can be found in when you click on "Get Code" on your offer page and it will be the URL that comes after "<img src=" inside your button code.

The other way to fix this is to switch to the "advanced" editor and turn OFF "rich formatting" and then it will interpret the BBcode correctly. Once the code is inserted, you should be able to switch back to the visual editor if you so choose.

2. If you have special characters in the name of your product or offer, it can confuse PayPal's system. Avoid using characters such as [,<,*,>, or ]
(Note: this is for the name of your product within WarriorPlus, not the thread title on the Warrior Forum)

If your button isn't showing at all, you may need to turn on the advanced editing of your forum post in order to paste the code for your button. Make sure "Rich Formatting" is turned OFF so that you can edit your post in "plain text." BBCode doesn't always translate well in the normal editor.

Because the Warrior Forum and WarriorPlus are integrated, you do have to use the exact code provided at least once in your post. This is so that WarriorPlus can keep track of all of your stats for sales and traffic correctly. If the code is not used at least once, the correct stats will not be reported back.



Did this answer your question?